haproxy 1.3.15.3 for NSLU2

The only haproxy load balancer package for the NSLU2 is really, really old, and is installed as “optware” in /opt. With that in mind, here’s the 1.3.15.3 package, installed in root. Package : haproxy_1.3.15.5-2_armv5b.ipk Source : haproxy-1.3.15.5.tar.gz

Written By
Jeff

NSLU2 based load balancer

Another day, another project … A few days ago I put together an NSLU2-based load balancer using haproxy to do the load balancing. If you don’t have an NSLU2, go get one. Those things are incredible, and ridiculously useful. I’m using OpenSlug/BE, but any distro is awesome on these things. Hint: It takes some manual hacking of the haproxy.conf file and the init script to get it working from the optware packages.

Written By
Jeff